Problem
Invitation is sent successfully to a user for given Organization, however, user never receive the email that has the invitation link.
Root cause
Split backend server use SendGrid email service to send emails, this is an enterprise subscription-based service which is usually whitelisted for businesses. It is possible that emails from SendGrid is not whitelisted which will block incoming emails from Split.io
Solution
Contact your IT and request to whitelist SendGrid service.
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