Issue
When submitting a change request while using the Admin REST API to specify the approver contact, the request fails with 400 error.
{"code":400,"message":"Something was wrong","details":"","transactionId":"xxxxxxx"}
Root cause
This error is possible if the approver option is set in the environment that has the feature flag. When approvers are pre-selected, it is not allowed to specify an approver when submitting the change request, similarly to when submitting the change from Split user interface; the approver edit box will be greyed out.
Answer
Verify if the feature flag definitions belong to an environment that has approvers set in its permissions. If so, remove the approver contact and leave the approvers array empty in the JSON payload.
"approvers":[]
Comments
0 comments
Please sign in to leave a comment.