Your PHP SDK requires symfony/yaml in version 2.8 or 4.*. This breaks compatibility for some PHP 5.6 applications, even though you specify that you support from PHP 5.3.
Is there are reason why you are not just requiring: >2.8, so it includes the major version in between: 3.4.* ?
Output from composer:
- Installation request for symfony/yaml (locked at v3.4.29, required as >=2.0) -> satisfiable by symfony/yaml[v3.4.29].
- splitsoftware/split-sdk-php 6.2.0 requires symfony/yaml 2.8|4.* -> satisfiable by symfony/yaml[v2.8.0, v4.0.0, v4.0.1, v4.0.10, v4.0.11, v4.0.12, v4.0.13, v4.0.14, v4.0.15, v4.0.2, v4.0.3, v4.0.4, v4.0.5, v4.0.6, v4.0.7, v4.0.8, v4.0.9, v4.1.0, v4.1.1, v4.1.10, v4.1.11, v4.1.12, v4.1.2, v4.1.3, v4.1.4, v4.1.5, v4.1.6, v4.1.7, v4.1.8, v4.1.9, v4.2.0, v4.2.1, v4.2.10, v4.2.2, v4.2.3, v4.2.4, v4.2.5, v4.2.6, v4.2.7, v4.2.8, v4.2.9, v4.3.0, v4.3.1, v4.3.2].
Please sign in to leave a comment.